ネットワークビジュアライザーで RIP、CCNA とかの勉強で


ネットワークビジュアライザーで RIP、CCNA とかの勉強で
ネットワークビジュアライザーで RIP、CCNA とかを練習しました。

過程を整理してご参考になれば、よかったです。

下記のネットワーク図のようなネットワーク構成のRIPを設定してみます。

図 : 今回のネットワーク図

「CCNAバーチャルラボ Network Visualizer 5.0」を使います。

ステップ一 : ネットワーク図を参照して、設定する必要の要件を選択します。

ネットワーク構成はとてもシンプルです。

各ルータの設定要件は下記の通りです。

ルータは下記のとおり設定します。

ルータA

インターフェイス「0」 に IP [192.168.30.1/24] を設定します。

インターフェイス「1」に IP [192.168.10.1/24] を設定します。

RIPで192.168.10.0 の情報を渡します。

ルータB

インターフェイス0 に IP [192.168.30.2/24] を設定します。

インターフェイス1 に IP [192.168.20.1/24] を設定します。

RIPで192.168.20.0 の情報を渡します。

ルータはシスコの2600です。

ステップ二 : そこでホストA(192.168.10.2)からの情報が届けるかどうかを検証します。

ルータの名前を「RouterA」に設定して、イーサネット0と1のIPアドレスを切り替えます。

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z

Router(config)#hostname RouterA

RouterA(config)#interface fastethernet 0/0

RouterA(config-if)#ip address 192.168.30.1 255.255.255.0

RouterA(config-if)#no shutdown

xx:xx:xx %LINK-3-UPDOWN:  Interface Fastethernet0/0, changed state to up

xx:xx:xx %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/0, changed state to up

RouterA(config-if)#exit

RouterA(config)#interface fastethernet 0/1

RouterA(config-if)#ip address 192.168.10.1 255.255.255.0

RouterA(config-if)#no shutdown

xx:xx:xx %LINK-3-UPDOWN:  Interface Fastethernet0/1, changed state to up

xx:xx:xx %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/1, changed state to up

RouterA(config-if)#exit

ルータの名前を「RouterB」に設定し、イーサネット0と1のIPアドレスを切り替えます。

Router>enable

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z

Router(config)#hostname RouterA

RouterB(config)#interface fastethernet 0/0

RouterB(config-if)#ip address 192.168.30.2 255.255.255.0

RouterB(config-if)#no shutdown

xx:xx:xx %LINK-3-UPDOWN:  Interface Fastethernet0/0, changed state to up

xx:xx:xx %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/0, changed state to up

RouterB(config-if)#exit

RouterB(config)#interface fastethernet 0/1

RouterB(config-if)#ip address 192.168.20.1 255.255.255.0

RouterB(config-if)#no shutdown

xx:xx:xx %LINK-3-UPDOWN:  Interface Fastethernet0/1, changed state to up

xx:xx:xx %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/1, changed state to up

RouterB(config-if)#exit

レスポンス分析

→ルータAのインターフェイス 192.168.10.1

OK

→ルータAのインターフェイス 192.168.30.1

OK

→ルータBのインターフェイス 192.168.30.2

NG

原因 : ルータBは帰りのルート(192.168.10.0宛)が分かりません。

→ルータBのインターフェイス 192.168.20.1

NG

原因 : ルータAは行き先のルート(192.168.20.0宛) が分かりません。

→ホストBのインターフェイス 192.168.20.2

NG

原因 : ルータAは行き先のルート(192.168.20.0宛) が分かりません。

ステップ三 : RIPを利用して問題を解決します。

手でルータBからRIPのアナウンスをさせます。

RouterB>enable

RouterB#configure terminal

RouterB(config)#router rip

RouterB(config-router)#network 192.168.20.0

そうするとRIPのパケットをブロードキャスト始まります。

RouterB#debug ip rip

RIP protocol debugging is on

9  23 23:16:58.221: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.30.2)

9  23 23:16:58.221: RIP: build update entries

9  23 23:16:58.221:  subnet 192.168.20.0 metric 1

9  23 23:16:58.221: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.20.1)

9  23 23:16:58.221: RIP: build update entries – supressing null update

0 からは 192.168.20.0 の情報を渡しますが、1からは何も渡していません。

この時点でルータAには192.168.20.0の宛先情報が届いていますが パケットモニタ で確認できましたけど、このままで

は受け入れずに破棄されてしまいます。

そこで、ルータAにも同様にRIPを設定します。

情報が届けるかどうかを検証します。

さて、ローカルのスタティックな設定では問題が2つありました。

1、ルータAは行き先のルート(192.168.20.0宛)が分りません。

2、ルータBは戻りのルート(192.168.10.0宛)が分かりません。

これらはルーティングテーブルからみれば、RIPによって解決されました。

そこでホストAからの届けるかどうかを再度検証してみます。

→ルータAのインターフェイス 192.168.10.1 OK

→ルータAのインターフェイス 192.168.30.1 OK

→ルータBのインターフェイス 192.168.30.2 OK

原因:ルータBは帰りのルート(192.168.10.0宛)をRIPによって分かりました。

→ルータBのインターフェイス 192.168.20.1 OK

原因:ルータAは行き先のルート(192.168.20.0宛)をRIPによって分かりました。

→ホストBのインターフェイス 192.168.20.2 OK

よって動的ルーティングの設定は成功しました。いい勉強になりました。


相関記事:




IT 資格 1 2 3
該当ウェブサイトはCisco Systems, Inc.、Microsoft、Oracle、CompTIA、Linus Torvolds,或いは他の認証機関が自社出資で開発するものではないし、他社に依頼して開発する物ではない。勿論、それらの集団の傘下に入るものではない。それに各集団は各自の商標だけ登記している。 例えば: Cisco Systems, IncはCisco™とCiscoシステム登記商標。Windows™のほうはMicrosoft登記商標。CompTIAはA+™、Network+™とServer+™と言う登記商標です。即ち:ここでリストした登記商標が各自の所有者に属するだけです。
COPYRIGHT © 2017 CERTCHOICE.NET ALL RIGHTS RESERVED